abs removed now rears locking up


bobbarron

Member
Joined
Feb 21, 2012
Messages
37
I have recently removed the abs from my ek9 and now when i apply the brakes the rears are locking up badly!
My brake specs are spoon twinblocks calipers with endless e slotted discs with yellow stuff pads. Rears are mtec slotted discs with yellow stuff pads aswell. Ive used a 40/40 non abs prop valve but unsure why they are locking out so easily!
Ive bought a pair of bias valves as i want to keep the split system incase of failure. I was going to stick them on and balance them out on brake rollers.
Is there anything i could try before i go sticking in a bias? Thanks in advance for any input
 



JDM_DAVE

Active Member
Joined
Nov 13, 2013
Messages
194
I think maybe it something to do with the prop valve or the way you have run the lines imo
 


jesse888

Ek9+Turbo+Nurburgring= Heaven
Staff member
Donator
Joined
Oct 16, 2012
Messages
8,932
Got to be the lines mixed up some how.
Even if your brakes where binding or something it shouldn't lock the rear easy. ESP with yellowstuff pads.
Check your lines are correct.
 


bobbarron

Member
Joined
Feb 21, 2012
Messages
37
Ive used oem pipes from a non abs ek so its not possible to mix pipes up! I got my 40/40 prop valve from eternal blue 2000 on here. Maybe he sent me the wrong one by mistake! Is there any markings on the valve that i can check?
 




eternal blue 2000

Donator
Donator
Joined
Jul 23, 2008
Messages
4,247
Ive used oem pipes from a non abs ek so its not possible to mix pipes up! I got my 40/40 prop valve from eternal blue 2000 on here. Maybe he sent me the wrong one by mistake! Is there any markings on the valve that i can check?
Correct valve was sent, its a 6 port valve so wrong one cant be sent as such.
As said check all lines properly hooked up, if there is a problem regarding valve i will sort it out no problem btw but you need to be sure thats the issue first.
 


Ernie

Active Member
Joined
Oct 15, 2010
Messages
590
There are diffrent ratio non abs prop valves... not all are 40/40....
 


jesse888

Ek9+Turbo+Nurburgring= Heaven
Staff member
Donator
Joined
Oct 16, 2012
Messages
8,932
Did you get to the end of this in the end?
 


bobbarron

Member
Joined
Feb 21, 2012
Messages
37
Sorry guys been mad busy! Yes ive double checked all pipes are correct. I had the same brake set up with abs and had no issues. I think i might try another prop valve before i start cutting up brake pipes to fit my bias valves. Do you only get 40/40 non abs prop valves?
 


StevieG

Active Member
Joined
Mar 7, 2011
Messages
539
No, not all non abs prop valves are 40/40. I had either a 35/40 or 30/40 can't quite remember which it was when I removed the abs from my dc2. Still my brakes where fine with this valve. I now have a wilwood adjustable valve in the car and also no troubles.
 


Top