Ek9 NCT Emissions Failure


soxturf

Member
Joined
Jun 27, 2009
Messages
675
Hi folks,

Unfortunately my car has failed the NCT (Irish equivalent of MOT) due to an emissions failure. (Its failing on high idle).

I originally thought it was the cat an replaced it with a new cat but still no joy.

After it failed the second time, the nct tester said that the emissions are fluctuating wildly, both up an down, above and under the required limit.

I replaced the 02 sensor an reset the ECU. I checked the voltage of the new 02 sensor an it is staying between 0.5 and 0.7. Obviously it should be fluctuating between 0.1 & 0.9. Just incase the new 02 sensor was faulty, I tried another new 02 sensor an checked the voltage again. It is still staying between 0.5 & 0.7. When I let the car out or accelerate hard, the voltage can manage to go outside the 0.5 to 0.7 range, but for the most part, especially when just idling, it is staying stuck between 0.5 & 0.7 meaning it is telling the car it's running rich an needs to lean up, which it obviously is not doing properly as the emissions fluctuate wildly an then it fails on high co2 meaning running rich.

Has anyone else ever seen their 02 sensor behave this way or had the same problem?

I own the car 13 years an never plan to sell it so this is cracking me up. Its not my daily, so now its just sitting in shed connected to trickle charger. Really want to get it back on road as I have big plans for it.
 


Civicfacelift

ej9 and eg6
Joined
Jan 15, 2011
Messages
605
Is there an additive you can put in petrol just for test ? or a more restrictive exhaust ?

That's just covering the problem though, if its running rich you will need to find the real cause.
 


Top