Conversion harness.... which one?


lexcoles

Active Member
Joined
Dec 25, 2013
Messages
185
Hey guys, just wondering what brands people have used and the experience you've had with that product, I'll be looking to purchase one soon, I've heard stories about some harnesses being poorly made and the plugs coming off them etc.

Any guidance or info would be great.
 


Ernie

Active Member
Joined
Oct 15, 2010
Messages
590
I've used K-Tuned, Rywire (both the same made by Rywire) and Sparkks Racing... All were very good with no problems. Worth mentioning the Sparkks harness is a fair bit cheper than the others... I am using Sparkks again on current K build.
 


oscarsayco

Well-Known Member
Joined
Jun 16, 2008
Messages
1,784
There is tons of options
hassport
hybrid
ktuned
rywire
wireworx
sparks
etc, etc...is just a thing of prefference and some cost a bit more than the others but is the same concept
 



si8pny

Well-Known Member
Joined
Sep 21, 2010
Messages
1,449
My Hybrid Racing one fell apart!

I have a Hassport one now and no issues with that.
 


lexcoles

Active Member
Joined
Dec 25, 2013
Messages
185
Cheers for the advice guys, ended up buying a ktuned harness, just waiting on delivery now
 


thuongk20

Member
Joined
Jun 28, 2011
Messages
440

Ernie

Active Member
Joined
Oct 15, 2010
Messages
590
Dont forget to do this before you fit everything together otherwise the o2 sensor wont work. Thats if you are running k20a2 and PRA ecu of course...

http://www.civiclife.net/board/topi...mary-sensor-how-to-guide-with-photo-of-plugs/

Also ktuned use different colour wires so heres a reference to their harness.. dont however follow the rest of it as its a guide to wire up a wideband sensor.

http://www.k20a.org/forum/showthread.php?t=91229&page=3#/forumsite/20715/topics/91229?page=1

We tried doing this today but cannot get it to work as there is no wire in pin 12 of the C302 plug?

Also are you depinning E4 and Pin 1 and 2 in the C302 plug or splicing into all 3 of them..?
 


thuongk20

Member
Joined
Jun 28, 2011
Messages
440
Its hard to explain without looking at it now lol. From what i remember.. 2 of the wires from the secondary o2 sensor is wired up correctly.. so I spliced my primary o2 sensors into them... only one wire from my o2 sensor was wired correctly...
 


Ernie

Active Member
Joined
Oct 15, 2010
Messages
590
Its hard to explain without looking at it now lol. From what i remember.. 2 of the wires from the secondary o2 sensor is wired up correctly.. so I spliced my primary o2 sensors into them... only one wire from my o2 sensor was wired correctly...

Ok thanks.. think I was looking at the plug from the wrong side! lol

Gonna have another go at it tomorrow...
 


thuongk20

Member
Joined
Jun 28, 2011
Messages
440
Ok thanks.. think I was looking at the plug from the wrong side! lol

Gonna have another go at it tomorrow...

yup i did the same. Until i found that ktuned link i was lost for days as im not very electronically minded. But with the two guides together it made a lot more sense.

Good luck man!
 


Ernie

Active Member
Joined
Oct 15, 2010
Messages
590
yup i did the same. Until i found that ktuned link i was lost for days as im not very electronically minded. But with the two guides together it made a lot more sense.

Good luck man!

Tried again today and think we have it right now.... finally!
 



thuongk20

Member
Joined
Jun 28, 2011
Messages
440
Good man! Its the niggly bits that can ruin a kswap.. but once done and the car is running 100percent its so rewarding. Ive seen so many kswaps with the eml on because of o2 sensors lol
 


Linas

New Member
Joined
Apr 29, 2013
Messages
22
Dont forget to do this before you fit everything together otherwise the o2 sensor wont work. Thats if you are running k20a2 and PRA ecu of course...

http://www.civiclife.net/board/topi...mary-sensor-how-to-guide-with-photo-of-plugs/

Also ktuned use different colour wires so heres a reference to their harness.. dont however follow the rest of it as its a guide to wire up a wideband sensor.

http://www.k20a.org/forum/showthread.php?t=91229&page=3#/forumsite/20715/topics/91229?page=1
Can I do the same rewire for my JDM K20A with Kpro4 in PRA ECU and Ktuned wiring harness?
As I have issues now with primary O2 sensor.
 



ominus1000

New Member
Joined
Sep 18, 2020
Messages
1
Car(s)
Civic eg9 kswap
Sorry bring back from the dead this post but is anyone know how to rewire the ktuned conversion harness for pra ecu?because the link for the civiclife is not working anymore because the forum is dead
 


Top